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What's SuperCon 2000?
CONTENTS

SuperCon 2000, formerly titled Converter II, is the most configurable and versatile unit conversion 
program in the world, featuring Explorer-style user interface, lots of available conversion units included, 
batch conversion, quick reference, conversions between decimal, binary, octal and hexadecimal numbers,
and much much more! Its intuitive user interface allows students to math experts to enjoy various unit 
conversions.

SuperCon 2000 handles the conversion format [Base unit] = [Conversion Factor] x [Non-standard 
unit] + [Y-intercept]. The extendable conversion table, containing 67 physical quantities and 760 units
of measurement, can be edited by means just like Windows Explorer. It can be also exported and 
imported as a text document. Each table can contain up to 200 physical quantities and 100 units per each
quantity, i.e.; up to 20,000 units in total. You may share it with other people in you office, lab and 
classroom.

A high-performance math expression evaluator ExCalc is attached to enable data exchange with 
SuperCon 2000.
 
SuperCon 2000 will answer the practical needs for engineers, students and those who have the 
necessity to use considerable number of physical quantities and units for special purposes.

Note: European characters such as "å" and "ö" may not be correctly displayed in some Windows 
environments other than English-language version.

Trademark acknowledgments: Microsoft, Windows, Internet Explorer and Visual Basic are registered trademarks of Microsoft 
Corporation. Register Now! is trademark of Universal Commerce, Inc. VeriSign is trademark of VeriSign, Inc.



       
Requirements
CONTENTS

Operating System

For Windows 98/95 only.

RAM

At least 8 MB free memory.

Monitor

Better than 256 color display.

Fonts

Arial, Courier New and Times New Roman must be at least installed.



       
Using Calculator
CONTENTS

Running Calculator

Click the  button or choose Run Calculator from the Tools menu to run the calculator or the application 
program which was selected in the Options dialog box. If Tek's (ExCalc) was chosen as the calculator, the
conversion result is sent to ExCalc's input box.

Sending the Conversion Result to ExCalc's Input Box

If Tek's (ExCalc) was selected as the calculator in the Options dialog box, click the  button or choose 
"Send Result to Calculator" from the Edit menu to send the conversion result to ExCalc's input box.

Sending the Calculation Result to the Convert-from Box 

If Tek's (ExCalc) was selected as the calculator in the Options dialog box, click the  button or choose 
"Get Calculation Result" from the Edit menu to send the calculation result to the Convert-from box.

See ExCalc's help document for further details.



         
Exiting SuperCon 2000
CONTENTS

Click the  button or choose Exit from the File menu.



       
Converting Units
CONTENTS

When you start SuperCon 2000, the main window opens, where you convert units, edit the conversion 
table and select menu items.

The main window mainly consists of the following parts:

 Physical Quantity Tree on the left, which displays the root item (the file name of the conversion table),
categories which groups physical quantities, physical quantities, Number System and Physical Constants.

 Unit List on the right, which displays units included in the selected physical quantity.

 Convert-from box below the Physical Quantity Tree, where you enter a number or drop a unit to be 
converted from.

 Convert-into box below the Unit List, which shows a conversion result or you drop a unit to be 
converted into.

 Status bar at the bottom, which shows the names of the units to be converted from and into.

 Caption bar, Menu bar and Toolbar at the top

Converting units by SuperCon 2000 is quite easy:

 Click one of the physical quantity name or its icon, displayed in the Physical Quantity Tree, which you 
want to make conversions. The units contained are shown in the Unit List.

Alternatively, shift focus over the physical quantities with the Tab key and press the Enter key.

 Click (with the mouse left button) a unit name or its icon shown in the Unit List. This will be the unit to 
be converted from. The unit name will be shown in the second panel on the status bar.

Alternatively, you may shift focus over the units with the Tab key and press the Shift and the Enter keys at the same time, or drag 
the unit name or its icon and drop it into the Convert-from box. The background color will change to let you know the selected unit 
can be dropped. 

 Right-click another unit name or its icon shown in the Unit List. This will be the unit to be converted 
into. The unit name will be shown in the fourth panel on the status bar.

Alternatively you may shift focus over the units with the Tab key and press the Enter key, or drag the unit name or its icon and drop it
into the Convert-into box. The background color will change to let you know the selected unit can be dropped. 
 

 As you type a number into the Convert-from box, a converted result will be immediately shown in the 
Convert-into box.

You can use either a dot (".") or a comma (",") as decimal separator regardless of the locale of 
your operating system. However, you must in no case use them as thousands separator.

 Right-click the arrow or its vicinity between the Convert-from and Convert-into boxes to swap the units.

 When you filled the Show Rounding Error check box in the Options dialog box, SuperCon 2000 
automatically calculates and displays the total rounding error in the converted result. When the entered 
value is not exact, add "?" at its end. See Examples 2 and 3 below.

 You can adjust the width of the Physical Quantity Tree and the Unit List by dragging the splitter right or 



left.

 You may change the widths of the Convert-from and Convert-into boxes by dragging the arrow or its 
vicinity between them.

Example 1: Drop "kilogram (kg)" into the Convert-from box and "pound (lb)" into the Convert-into box, 
and enter "12" in the Convert-from box. When you emptied the Show Rounding Error check box, you will 
get "26.4555" in the Convert-into box, which means 12 kg = 26.4555 lb.

Example 2:    When you filled the Show Rounding Error check box in Example 1 above, SuperCon 2000 
will give "26.4555 ±2.92E-07", which means the total rounding error is ±0.000000292 including the 
rounding errors in the conversion factors.

Example 3: When you enter "12.000?" in Example 2 above, SuperCon 2000 understands the rounding 
error of 12.000 is 0.0005 and gives "26.4555 ±1.10E-03", which means the total rounding error is 
±0.00110 including the rounding errors both in the entered value and the conversion factors.    

In the Unit List the top unit is of SI unit in principle, when not sorted, and displayed with the red icon.



       
Copying/Pasting Data
CONTENTS

Other than the Windows' standard copy and paste method, i.e.; selecting what you want to copy or paste 
with the pop-up menu which appears by right-clicking it, SuperCon 2000 provides the following 
convenience:

Choose "Copy Conversion Result" from the Edit menu or click the  button to send the conversion result 
to the clipboard. Choose "Paste as Conversion Input" from the Edit menu or click the 

 button to send the text on the clipboard to the Convert-into box of the main window.

You can send the information of the selected unit to the clipboard by choosing Unit Properties from the 
Edit menu.

The copy history is displayed when you choose History from the Edit menu. You click one of the items to 
restore the contents on the clipboard.    



     
Changing the Configuration Settings
CONTENTS

Click the  button or choose Options from the Tools menu to open the Options dialog box, where you 
change the configuration settings of SuperCon 2000 such as significant figures, number format, fonts, 
colors and calculator type.



       
File ([Alt] + [F])
CONTENTS

Open ([O])

Opens the Open dialog box where you choose a conversion table file to be imported to SuperCon 2000.

Save ([S])

Saves the contents of the conversion table presently displayed by overwriting the previously opened file.

Save As ([A])

Opens the Save As dialog box where you save the contents of the conversion table presently displayed 
as a text document file.

Print ([P])

Prints the conversion table presently displayed.

Start Batch Conversion ([B])  

Opens the Open Batch Conversion Data File dialog box to start Batch Conversion.

In this dialog box you choose a batch conversion data file. Click the OK button after choosing a file name 
to start batch conversion.

After batch conversion being started, this menu item changes to Quit Batch Conversion, so choose this 
menu item if you want exit the batch conversion mode.

Exit ([X])

Exits SuperCon 2000.



       
Edit ([Alt] + [E])
CONTENTS

Copy Conversion Result ([Ctrl]+[C])

Sends the conversion result to the clipboard.

Copy Unit Properties ([U])

Sends the properties of the selected unit to the clipboard.

Paste as Conversion Input ([Ctrl] + [V])

Sends the text in the clipboard to the Convert-from box.

Get Calculation Result ([G])

Sends the calculation result done by ExCalc to the Convert-from box if you chose Tek's (ExCalc) as the 
calculator in the Options dialog box.

Send Result to Calculator ([R])

Sends the conversion result to ExCalc's input box if you chose Tek's (ExCalc) as the calculator in the 
Options dialog box.

History ([H])

Displays up to eight (8) conversion contents sent to the clipboard in the past. Click one of the items to 
restore the content on the clipboard.    

Find ([Ctrl]+[F])

Opens the Find dialog box to find units or physical quantities which include the specified word.



       
Notes on Conversions
CONTENTS

Reference

English expressions in the default conversion table was mainly based on the following document 
(Reference 1):

Reference 1) Guide for the Use of the International System of Units (SI), National Institute of Standards and 
Technology (NIST) Special Publication 811, 1995 Edition, by Barry N. Taylor

The conversion factors SuperCon 2000 actually employs were totally reconstructed as values with the 
significant figures of 15, based on the strict base conversion factors such as foot to meter, pound to 
kilogram, BTU to joule, gallon to cubic meter, etc. Therefore, the conversion factors SuperCon 2000 
employs are far accurate than the data referred.

It's worth visiting http://www.unc.edu/~rowlett/units/index.html for the perfect listing of units of 
measurement.

Conversion Table Backup

The backup of the original conversion table is enclosed as DEFAULT_BAK.DAT. If you want to restore 
the conversion table, open DEFAULT_BAK.DAT and save it with a different file name. You can download 
the latest conversion table from our web site http://www.hitekdesign.com or 
http://village.infoweb.ne.jp/~tek/index.htm.

Number System

The entered values for conversions between binary, octal, hexadecimal and decimal numbers must be 
positive. If you enter a negative value, an error message is given in the Convert-into box. Entering a too 
large value also results an error message.

A hexadecimal or an octal number is converted to a decimal number simply as a sum of n-th digit times 
16^(n-1) or 8^(n-1). It does not give -1 for &HFFFF. The largest binary number SuperCon 2000 can 
handle is 65535.

Speed of Sound

- Mach number is a ratio of a speed to the sound speed a m/s, which is based on the equation below for 
dry air under the pressure of 1 atm.

a = 331.68 SQRT{(273 + T) / T},

where T is temperature in ºC.

- Sound speed in pure water v in m/s is based on the Greenspan-Tschlegg's equation:

v = 1402.736 + 5.03358 * T - 0.0579506 * T^2
                              + 3.31636E-4 * T^3 - 1.45262E-6 * T^4
                              + 3.0449E-9 * T^5,

where T is temperature in ºC.

- Sound speed in sea water v in m/s is based on the equation below (Reference 2):



v = 1448.96 + 4.591 * T - 5.304E-2 * T^2
           + 2.374E-4 * T^3 + 1.340 * (S - 3.5)

          + 1.630E-2 * D + 1.675E-7 * D^2
              - 1.025E-2 * T * (S - 3.5) - 7.139E-13 * T * D^3,

where T is temperature in ºC, S is salinity of sea water in % (S = 3.5 is applied) and D is water depth in 
meter (D = 10 is applied).

Reference 2) Mackenzie, K. V.: Nine-term Equation for Sound Speed in the Oceans, J. Acoust. Soc. Am., 70:807 
(1981)

Miscellaneous

- The maximum absolute value which SuperCon 2000 supports is within the range from 4.94E-324 to 
1.79E+308. Conversion results must be also within this scope.

- The default conversion table uses 9.80665 m/s² as the value of the acceleration of free fall.

- "ångström", "örsted" and "röntgen" are expressed as "angstrom", "oersted" and "roentgen" in English.



       
Peculiar Units
CONTENTS

- Sound speed v in m/s is based on the formulae below at the pressure of 1 atm.

In pure water: v = 1404.4 + 4.8215 * T - 0.047562 * T² + 0.00013541 * T³,
In air: v = 331.68 * SQRT(273.15 - T) / 273.15,
In sea water: v = 1449.2 + 4.623 * T - 0.0546 * T² + 1.391 * (S - 3.5),

where T is temperature in ºC and S is salinity of sea water in % (S = 3.5 is applied).

- "ångström", "örsted" and "röntgen" are expressed as "angstrom", "oersted" and "roentgen" in English.



SI Unit
Système International d'Unités (International Unit System) originally formed in 1960



       
Technical Support
CONTENTS

E-mails for technical support on this software are accepted at support@hitekdesign.com or 
tekdesign@nifty.com.

This software is continuously maintained and the program together with the conversion tables are 
updated from time to time. You can download them from our web site http://www.hitekdesign.com or 
http://village.infoweb.ne.jp/~tek/index.htm. You may at times visit there to check the version number 
and/or the time stamp of the released file.

This software has grown out of necessity and feedback from end users. It's our important policy to respect
end user's opinions and try our best to meet their requests. We sincerely hope you enjoy using this 
software, and if we can be of any help whatsoever, please feel free to drop us a message.



       
Options Dialog Box
CONTENTS

This dialog box opens when you click the  button or choose Options from the Tools menu.

In this dialog box you can change the configuration settings of SuperCon 2000. All of the settings are 
saved on exit and restored next time you run SuperCon 2000.

Number Style Panel ([N])

- Show Rounding Error ([E]) 

Fill this check box if you want to let SuperCon 2000 automatically calculate and show a rounding error.

- Show Number Always in Integer Format ([I])

Fill this check box to show the conversion result always in integer format.

- Number Format ([U])

Choose Regular to show the results in regular notation, or else choose Scientific.

- Significant Figures ([S])

Choose a number of significant figures for conversion results from 4 to 12 by using the slider.

- Use Scientific Format for Numbers above 10^N or below 10^(-N): N = ([0])

In cases such that the result has too many zeros to be correctly read out, it can be automatically shown in
scientific format even if Regular was chosen for number format. If you want to have the result shown in 
scientific format when its absolute value is below 10^(-N) or above 10^N, enter a number of N in the "N ="
box.

Choose "NA" if you do not want to apply this option. Note that, regardless of this setting, the conversion 
result will be automatically shown in scientific format when its integer part has more digits than the 
Significant Figures setting. For example, 508370000 is always shown as 5.08370E+08 when the 
Significant Figures setting is 6. This consideration always enables exact expression of significant figures.

- Preview

The display style of the conversion result is shown here.

General Panel ([G])

- Allow Modification to Conversion Table ([A])

Fill or empty this check box if you allow or do not allow modification to the conversion table presently 
displayed. If you filled this check box, the Physical Quantity Tree and the Unit List cannot be modified at 
all. It is recommended to empty this check box to protect the conversion table from being undesirably 
modified.

- Save Windows Position and Size ([P])

Fill this check box if you want to save the main window position and size on exit.



- Show Toolbar ([B])

Fill or empty this check box to show or hide the toolbar.

- Show Menu Bar ([M])

Fill or empty this check box to show or hide the Menu bar. Note that both of the Toolbar and the Menu bar 
cannot be hidden.

- Show Grid Lines in Detailed Unit List ([D])

Fill or empty this check box to show or hide the grid lines in the Unit List when Details is chosen in the 
View menu.

- Show Main Window Always on Top ([T])

Fill this check box to show the main window always on the top.

- Fonts and Colors ([F])

Click the item in the drop-down list to show the Font and Colors dialog box, where you set the font 
properties and the background colors for each display area in the main window and the text boxes in each
dialog box, and for printing the conversion table.

- Calculator and Program ([L])

Choose one of the calculator types which you want to run when the  button is clicked or Run Calculator 
is chosen from the Tools menu. If you select Others, you must enter the full path to the executable file of 
the optional calculator in the "Full Path to Executable File" box. You can specify any programs in place of 
calculator if they can be started without parameters. Click the [...] button to locate the file.

When you choose Run Program from the Tools menu, you can run the specified program such as your 
favorite text editor for example if you enter the full path to its executable file and select Tek's (ExCalc) or 
Window's as the calculator. If you empty the "Full Path to Executable File" box and select Others as the 
calculator, you can run NotePad when you choose Run NotePad from the Tools menu.



       
Font and Colors Dialog Box
CONTENTS

This dialog box opens when you click one of the items in the Fonts and Colors drop-down list in the 
General panel of the Options dialog box.

In this dialog box you can set the text font properties and the background color for each display area in 
the main window and the text boxes in each dialog box, and for printing the conversion table.

In the Properties panel select the font name, size and style. Click  or 
 button to open the Color dialog box where you select the text or background color respectively. Some 

boxes and buttons are disabled for the Convert-into box, the status bar, the text boxes in each dialog box 
and Print. Note that an improper font size may cause an unexpected result, so it is limited from 8 through 
14 points. When you enter a size beyond the bounds, it will be automatically corrected.

It is recommended to choose a fixed width font like Courier or Courier New for Print.



       
Open Dialog Box
CONTENTS

This dialog box opens when you click the  button or choose Open from the File menu.

In this dialog box you can import a conversion table file to SuperCon 2000. Click the OK button after 
choosing a file name. The file selected in this dialog box will be also opened next time you run SuperCon 
2000.



       
Save As Dialog Box
CONTENTS

This dialog box opens when you click the  button or choose Save As from the File menu.

In this dialog box you can save the contents of the conversion table presently displayed. Click the OK 
button after entering a proper file name in the File Name box. When you choose the existing file name, 
the warning message will ask you if it may be overwritten.



       
Installing/Un-installing SuperCon 2000
CONTENTS

Installing SuperCon 2000

You must have successfully installed SuperCon 2000 when you read this Help.

It is not recommended to place the shortcut to SuperCon 2000 in the Windows' Startup folder since it 
rarely causes abnormal display of the window. When the window was abnormally displayed on startup, 
un-install SuperCon 2000 and install it once again.

The following information is provided for those who read this help document without running SuperCon 2000:

This program additionally requires the Visual Basic 5.0 runtime drivers (Service Pack 2 or higher). If you have already installed them
to your Windows system, skip step 1).

1) Install Visual Basic 5.0 runtime drivers (Service Pack 2 or higher) if not installed yet. The setup module to install the required 
drivers can be downloaded from some software archive sites as freeware. For more information visit our web site 
http://www.hitekdesign.com or http://village.infoweb.ne.jp/~tek/index.htm and go to "Visual Basic Runtime Drivers".

2) Unzip the distributed file into an arbitrary folder.

3) Run SETUP.EXE and follow its instructions.

4) The files extracted into the temporary folder can be removed after the installation has been successfully finished.

In addition COMCTL32.DLL v. 4.72 or higher is also required but this file is typically installed with Internet Explorer 3.02 or higher 
included in Windows 98 and almost all Windows 95.

It is our stance that each distributed file should not always include runtime drivers because they are shared by programs and, by 
including them, each distributed (compressed) file would become considerably large.

Un-installing SuperCon 2000

Launch Add/Remove Programs in the Control Panel and choose SuperCon 2000.



       
License Agreement
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You accept the following Agreement by receiving and/or using this Software. If you do not intend to honor 
this Agreement, you must remove this Software from your computer right now.

Distribution

You may distribute or reproduce the evaluation copies of this Software freely. However, it is desirable to 
contact us by E-mail to get our consent preferably prior to, or even after, the distribution or the 
reproduction if it is done by public media.

All of the components of this Software should be distributed or reproduced in the original archive form and
should not be modified in any way. No money is charged to the person receiving this Software as well. 
 
The distribution must not include a registration number. In particular, you must not distribute a registered
version of this Software.

Evaluation and License

You may evaluate this Software for maximum of continuous 30 calendar days, at the end of which you 
must register this Software, or you must immediately remove this Software from your computer.    

You may allow other users to evaluate the evaluation copies of this Software. All evaluation users are 
subject to the terms of this Agreement.

The evaluator and user of this product will indemnify, hold harmless, and defend Tek Design and the 
author against lawsuits, claims, costs associated with defense or accusations that result from the use of 
this product which means the Software itself and all of the components attached to the Software. This 
Software is provided "as is" without warranty of any kind. Tek Design and the author disclaim all 
warranties, including without limitation any implied warranties of merchantability, fitness for a particular 
purpose, and non-infringement. The entire risk arising out of the use or performance of the product and 
documentation remains with recipient. In no event shall Tek Design and the author be liable for any 
consequential, incidental, direct, indirect, special, punitive, or other damages whatsoever (including, 
without limitation, damages for loss of business profits, business interruption, loss of business 
information, or other pecuniary loss) arising out of this Agreement or the use of or inability to use the 
product, even if Tek Design or the author has been advised of the possibility of such damages.

One user may use each registered copy of this Software in only one single location. Use of the Software 
means that you have loaded the program and run it or have installed the program onto a computer. If you 
install the Software onto a multi-user platform or network, each and every individual user of the Software 
must be separately registered.

You may make one copy of the registered Software for backup purposes, providing you only have one 
copy installed on one computer being used by one person. If any person other than yourself uses this 
Software registered in your name, regardless of whether it is at the same time or different times, then this 
Agreement is being violated.    

The sale of and/or distribution of registered copies of this Software are strictly forbidden. It is a violation of
this Agreement to loan, rent, lease, borrow, or transfer the use of registered copies of this Software.

Copyright Notice

None is allowed to attempt to reverse engineer, disassemble or decompile this Software. All parts of this 



Software are copyright protected.

Copyright © 2000-2001 by Tek Design. All Rights reserved.



       
View ([Alt] + [V])
CONTENTS

List ([L])

Displays the Unit List only with icons and names.

Details ([D])

Displays the Unit List in detail with icons, names, conversion factors, Y-intercept and memo.

Arrange ([A])

- Quantities by Name ([Q])

Sets the unit physical quantities alphabetically sorted or not sorted. Note that the Physical Quantity Tree 
cannot be scrolled by mouse and the physical quantities cannot be moved when alphabetically sorted.

- Units by Name ([U])

Sets the units alphabetically sorted or not sorted. Note that the Unit List cannot be scrolled by mouse and 
the units cannot be moved when alphabetically sorted.



       
Tools ([Alt] + [T])
CONTENTS

Run Calculator ([Ctrl] + [K])

Runs the calculator or the program specified in the Options dialog box.

Run NotePad, Run Program ([R])

Runs NotePad or the program specified in the Options dialog box. You can specify any program such as 
your favorite text editor for example if you enter the full path to its executable file and select Tek's 
(ExCalc) or Window's as the calculator. You can run NotePad if you empty the "Full Path to Executable 
File" box and select Others as the calculator.

Quick Reference ([Ctrl] + [Q])

Shows the Quick Reference Table for the selected physical quantity.

Options ([O])

Opens the Options dialog box, where you change the configuration settings of SuperCon 2000.



       
Editing the Physical Quantity Tree
CONTENTS

Adding a New Category  
 
 

Right-click the root item name or its icon to show the pop-up menu, where you choose Add to open the 
Category Properties dialog box. Enter a new category name in the Name box and choose an icon for it. A 
new category will be added just above the Number System. Note that each category name must be 
unique.

Moving the Physical Quantity     
 
 

Drag and drop the physical quantity name or its icon to change the relative position in the Physical 
Quantity Tree. The collapsed tree nodes are automatically expanded while scrolling the tree by dragging 
the tree item. Note that the root item, the categories, Number System and Physical Constants cannot be 
moved. Also note that the Physical Quantity Tree cannot be scrolled by mouse and the physical quantities
cannot be moved when alphabetically sorted.

Adding a New Physical Quantity

Right-click the category name or its icon to show the pop-up menu, where you choose Add to open the 
Physical Quantity Properties dialog box. Enter a new physical quantity name in the Name box and choose
an icon for it. A new physical quantity will be added at the bottom of the selected category. Note that each 
physical quantity name must be unique.

Inserting a New Physical Quantity

Right-click the physical quantity name or its icon to show the pop-up menu, where you choose Insert to 
open the Physical Quantity Properties dialog box. Enter a new physical quantity name in the Name box 
and choose an icon for it. A new physical quantity will be inserted just beneath the selected physical 
quantity. Note that each physical quantity name must be unique.

Deleting the Tree Item

Right-click the tree item name or its icon to show the pop-up menu, where you choose Delete to open the 
Confirm Item Deletion dialog box. Click the Yes button if you really want to delete the selected item. Note 
that the root item, the first (top) category, Number System and Physical Constants cannot be deleted.

Changing the Category or Physical Quantity Properties

Right-click the name or the icon of the category or the physical quantity to show the pop-up menu, where 
you choose Properties to open the Category Properties dialog box or the Physical Quantity Properties 
dialog box. Enter a new name in the Name box and choose an icon for it. You can rename the tree item 
by clicking the tree item name twice and directly enter a new name.





       
Editing the Unit List
CONTENTS

This topic describes how to edit the Unit List. In the Physical Constant Properties dialog box, the physical 
constants can be edited in the same way by reading "unit" as "constant" and "Unit Properties" as 
"Physical Constant Properties" respectively. 

Moving the Unit 

 
Drag and drop the unit name or its icon to change the relative position in the Unit List. Note that the Unit 
List cannot be scrolled by mouse and the units cannot be moved when alphabetically sorted. 

Adding a New Unit
 
Right-click the background or the places other than the unit names and the icons in the Unit List to show 
the pop-up menu, where you choose Add to open the Unit Properties dialog box. Enter properties for the 
new unit and choose an icon for it. The new unit will be added at the bottom in the Unit List. Note that 
each unit name must be unique. 

Inserting a New Unit
 
Move the mouse cursor to the unit name or its icon, press the right button and hold it for an instant to 
show the pop-up menu, where you choose Insert to open the Unit Properties dialog box. Enter properties 
for the new unit and choose an icon for it. A new unit will be inserted just beneath the selected unit. Note 
that each unit name must be unique.

Deleting the Unit
 
Move the mouse cursor to the unit name or its icon, press the right button and hold it for an instant to 
show the pop-up menu, where you choose Delete to open the Confirm Item Deletion dialog box. Click the 
Yes button if you really want to delete the selected item. Note that the items in Number System cannot be 
deleted.

Changing the Unit Properties

Move the mouse cursor to the unit name or its icon, press the right button and hold it for an instant to 
show the pop-up menu, where you choose Properties to open the Unit Properties dialog box. Enter 
properties for the new unit and choose an icon for it.

Note that the conversion factors in Temperature, if exists, should not be changed. This is recommended 
to exactly get 0 ºC for 32 ºF and 0 ºF for -17.7777... ºC.

If you want to rename the units "pixel (X)" and "pixel (Y)", if exist, in Graphics Units, run SuperCon 2000
with their default unit names at least once. SuperCon 2000 searches for the character strings "pixel (X)" 
and "pixel (Y)", and automatically sets their conversion factor for your computer. After this procedure you 
can rename them in the Unit Properties dialog box. This is required each time after you renewed your 
computer and/or installed SuperCon 2000. 

Renaming the Column Header



Right-click the background or the places other than the unit names and the icons in the Unit List to show 
the pop-up menu, where you choose Properties to open List Properties dialog box. Enter a new names in 
each Column box.

Adding/Editing Memo

Move the mouse cursor to the unit name or its icon, press the right button and hold it for an instant to 
show the pop-up menu, where you choose Show Memo to open the Memo window. Enter your favorite 
memo in the text box. Alternatively, you can open the memo window by clicking the unit name or its icon 
while pressing the Shift key and directly edit the memo. The memo can contain up to 256 characters per 
each unit. The icon will change to ,

,
 or 
 when a memo is added.



       
How to Register SuperCon 2000?
CONTENTS

Pricing

The registration fee for SuperCon 2000 is as shown below:

Number of copies Cost per copy
1-9 $10.00 U.S.
10-99 $8.00 U.S.
100+ $6.00 U.S.

Your registration information will be e-mailed to you once your order has been processed. You can also 
send cash money in several currencies by mail if you prefer. Please see the Registration Form for details.

Payment Method

a) On-line registration

You can register SuperCon 2000 on-line through Register Now! with Secure Socket Layer (SSL) security 
using a VeriSign Certificate from the following web page:

https://www.regnow.com/softsell/nph-softsell.cgi?item=3075-3

b) Send cash money by mail

Please send cash money (only notes except Yen) by mail along with the completed Registration Form to:

Yoshie Iyama
4-8-4-503 Yatsu, Narashino JAPAN
Postal code: 275-0026

The sender bears postal charges for sending the registration fee. Please also note the cash money sent 
to the above address must be exactly as much as the registration fee for the ordered license(s). No 
change can be returned to the sender.



       
What is Registration?
CONTENTS

SuperCon 2000 is Shareware. It means that this software is available to you for free evaluation. You are 
entitled to evaluate this software for 30 calendar days with no obligation to pay for the registration. After 
the evaluation period, if you find this software useful and decide to keep it, you must register your copy. 
Once you have registered your copy, the fee for future upgrades is totally free.

The registration information for Converter II is also valid for SuperCon 2000. If you are a registered user 
of Converter II, you can use the same registration code for SuperCon 2000.



       
Registration Form
CONTENTS

SuperCon 2000 Registration Form (for cash money only)

The items marked with an asterisk (*) are indispensable. In particular your e-mail address must be 
exactly written, otherwise your registration information may not reach you.

Date*____________________________

Name*__________________________________________

Street __________________________________________

City __________________ State/Province _____________

Country*___________________ Zip/PC ______________

E-mail address*__________________________________

Currency and Quantity*

[    ] I know I send cash money on my own risk. No coins are included (except Yen). The amount of 
cash money is exactly as much as the registration fee for the ordered license(s).



       
Physical Quantity Properties Dialog Box
CONTENTS

Right-click one of the category names, physical quantity names or their icon in the Physical Quantity Tree 
to show the pop-up menu, where you choose Properties to open the Physical Quantity Properties dialog 
box.

Name ([N])

Enter a unique physical quantity name.

Icon ([I])   
 
 

 
Choose one of the four icons for the selected physical quantity.



       
Unit Properties Dialog Box
CONTENTS

Move the mouse cursor to one of the unit names or the icons in the Unit List, press the right button and 
hold it for an instant to show the pop-up menu, where you choose Properties to open the Unit Properties 
dialog box.

Name ([N])

Enter a unique unit name.

Conversion Factor (Slope)

- Value ([V])

Enter a conversion factor in the Value box. The conversion format is [Base Unit] = [Conversion factor 
(Slope)] x [Non-standard unit] + [Y-intercept], where [Base Unit] is the unit shown at the top of the Unit
List when not sorted alphabetically and is ordinarily a SI unit, and    [Non-standard Unit] is the unit you are 
editing. Obviously, the conversion factor of the base unit should always be "1".

Example: Let the relation between the non-standard unit and the base unit be [Base unit] = 2.3 x [Non-
standard unit]. You enter "2.3" as [Conversion factor] and leave the other boxes blank in this case. 

- Error ([E])

If you have reliable information on the error for the conversion factor, enter the positive error value in the 
Error box. Enter "0" if you are sure that the conversion factor is exact and has no error. Note that you 
must leave the Error box blank if you want SuperCon 2000 to automatically calculate and show a 
rounding error with a conversion result, when the Show Rounding Error check box is filled in the Options 
dialog box. The rounding error for the conversion factor of the base unit should always be "0".
 
Y-intercept

- Value ([A])

Y-intercept is zero for ordinary units. If you want to define a conversion factors like temperature, which is 
expressed such as [Value in kelvin] = [Value in ºC] + [273.15], enter the Y-intercept in the Value box. The 
value of Y-intercept is "273.15" in this case. 

Example: Let the relation between the non-standard unit and the base unit be [Base unit] = 2.3 x [Non-
standard unit] + 3.7. You enter 2.3 as [Conversion factor] and 3.7 as [Y-intercept].



- Error ([R])

If you have reliable information on the error for the Y-intercept, enter the positive error value in the Error 
box. Enter "0" if you are sure that the Y-intercept is exact and has no error. Note that you must leave the 
Error box blank if you want SuperCon 2000 to automatically calculate and show a rounding error with a 
conversion result, when the Show Rounding Error check box is filled in the Options dialog box. The 
rounding error for the Y-intercept of the base unit should always be "0". 

Icon ([I]) 

Choose one of the four icons for the selected unit.

Memo ([M])

Enter your favorite memo in the text box. The memo can contain up to 256 characters per each unit. The 
icon will change to ,

,
 or 
 when a memo is added.



  
Conversion Table Format
CONTENTS

SuperCon 2000 employs a unit conversion table of which file type is text document. You can create or edit
the conversion table and let SuperCon 2000 import it. See TableFormat.doc enclosed with the distributed 
file for details. However, if you are not sure that you have completely understood the table format, it is not 
recommended to create or directly edit the table. It should be also noted that adding too many physical 
quantities and units may cause considerable time to be taken when reading the conversion table and 
exiting the program.



       
How to Unlock SuperCon 2000?
CONTENTS

Once you have registered SuperCon 2000, your registration code together with your registered user 
name will be e-mailed to you. Choose About from the Help menu to display About SuperCon 2000 dialog 
box. Click Register to open the Register SuperCon 2000 dialog box, where you enter the registered user 
name and the registration code exactly, and click the OK button. The same user name and the 
registration code are also valid for the upgraded versions.

The registration information for Converter II is also valid for SuperCon 2000. If you are a registered user 
of Converter II, you can use the same registration code for SuperCon 2000.



       
Toolbar
CONTENTS

The toolbar provides buttons which access the commands in the menus. If a button is unavailable, it 
appears grayed-out.

 Open: Opens the Open dialog box where you choose a conversion table file.

 Save As: Opens the Save As dialog box where you save the present conversion table as a text 
document file.

 Print: Prints the conversion table presently displayed.    

 Copy Conversion Result: Sends the conversion result to the clipboard.

 Paste as Conversion Input: Sends the clipboard contents (text) to the Convert-from box.
 

 Get Calculation Result: Sends the calculation result to the Convert-from box if you chose Tek's 
(ExCalc) as the calculator in the Options dialog box.

 Send Result to Calculator: Sends the conversion result to the calculator's input box if you chose 
Tek's (ExCalc) as the calculator in the Options dialog box.

 Find: Opens the Find dialog box to find units or physical quantities which include the specified word.

 List: Shows the Unit List with icons and unit names.

 Details: Shows the Unit List in detail with its icons, unit names, conversion factor, Y-intercept and 
memo. 

 Arrange Quantities by Name: Sets the physical quantities alphabetically sorted or not sorted. Note 
that the Physical Quantity Tree cannot be scrolled by mouse and the physical quantities cannot be moved
when alphabetically sorted.

 Arrange Units by Name: Sets the units alphabetically sorted or not sorted. Note that the Unit List 
cannot be scrolled by mouse and the units cannot be moved when alphabetically sorted.

 Quick Reference: Opens the Quick Reference Table. 

 Run Calculator: Runs the calculator (or the application program) defined in the Options dialog box.

 Options: Opens the Options dialog box where you change the configuration settings of SuperCon 
2000.

 Help: Opens SuperCon 2000 Help.

 Exit: Exits SuperCon 2000.



       
List Properties Dialog Box
CONTENTS

Right-click the background or the places other than the unit names and the icons in the Unit List to show 
the pop-up menu, where you choose Properties to open the List Properties dialog box.

Renaming the Column Header Text

Enter a new name in the Column box to rename the column header. If you insert "&" into the character 
string of the header name, the character just behind "&" will be the keyboard shortcut.



       
Physical Constant Properties Dialog Box
CONTENTS

Move the mouse cursor to one of the quantity names or the icons in the Physical Constants, press the 
right button and hold it for an instant to show the pop-up menu, where you choose Properties to open the 
Physical Constant Properties dialog box.

Name ([N])

Enter a unique quantity name.

Value ([V])

Enter the value for the quantity.

Unit ([U])

Enter the unit for the quantity..

Icon ([I]) 

 

Choose one of the four icons for the selected quantity.

Memo ([M])

Enter your favorite memo in the text box. The memo can contain up to 256 characters per each unit. The 
icon will change to ,

,
 or 
 when a memo is added.



       
Find Dialog Box
CONTENTS

This dialog box opens when you click the  button or choose Find from the Edit menu.

Select Unit or Quantity and enter a word or a part of word in the Find What box and click the Find Next 
button to find units or physical quantities which include the specified word. Fill the Match Case check box 
to find only units which include the same uppercase and lowercase characters as specified in the Find 
What box.



  
For Advanced Windows Users
CONTENTS

If you are an advanced Windows user, you can customize several special settings of SuperCon 2000 by editing the 
Windows' registry. Run Windows Registry Editor, open HKEY_CURRENT_USER\software\VB and VBA Program 
Settings\SuperCon 2000\Extra folder, and follow the instructions below. Note these changes should be done at the 
user's responsibility, and will be effective next time you start SuperCon 2000.

Customizing the toolbar

Right-click the CustomizeToolbar key and change the Value Data to "True".    After restarting SuperCon 2000, 
double-click the blank area in the Toolbar to open the Customize Toolbar dialog box, where you can rearrange or 
remove the buttons.

Customizing the scrolling speed

Right-click the ScrollTimerInterval key and change the Value Data from 50 to 1000 (ms). The default setting is 150 
(ms).

Customizing the delay to show the right-click menu on the Unit List

Right-click the ShowMenuDelay key and change the Value Data from 100 to 2000 (ms). The default setting is 500 
(ms).

Customizing the delay to pause scrolling the Unit List 

Right-click the ScrDownDelay key and change the Value Data from 100 to 2000 (ms). The default setting is 500 
(ms).



       
Showing the Memo for the List Items
CONTENTS

A memo which contains up to 256 characters can be attached to each unit and physical constant. The 
memo is shown in the fourth column in the Unit List. You can open the Memo window by clicking the unit 
name or its icon while pressing the Shift key. Alternatively move the mouse cursor to the unit name or its 
icon, press the right button and hold it for an instant to show the pop-up menu, where you choose Show 
Memo to open the Memo window.



       
Using the Quick Reference Table
CONTENTS

SuperCon 2000 provides the quick reference function to ease quick reference to conversion results for a 
set of numbers you usually use. The instructions below are based on the sample data for Temperature    
which were already incorporated.

Showing the Quick Reference Table

Choose Temperature from the Physical Quantity Tree and click  button. The Quick Reference Table 
which contains the preset data will be shown.

Moving the Reference Item

Drag and drop the unit name to change the relative position in the Quick Reference Table.

Adding a New Reference Item

Right-click the places other than the first column to show the pop-up menu, where you choose Add to 
open the Add dialog box. A new item will be added at the bottom. Note that each item name must be 
unique and the maximum number of items is 20.

Inserting a New Reference Item

Right-click the item name to show the pop-up menu, where you choose Insert to open the Insert dialog 
box. Enter a new name in the Name box and a value expressed as the base unit, which is shown at the 
top of the Unit List when not sorted alphabetically, in the "Value in SI or Base Unit" box, and click the OK 
button. A new item will be inserted just beneath the selected item. Note that each name must be unique.

Deleting the Reference Item
 
Right-click the item name to show the pop-up menu, where you choose Delete to open the Confirm Item 
Deletion dialog box. Click the Yes button if you really want to delete the selected item.

Changing the Reference Item Properties

Right-click the item name to show the pop-up menu. Choose Properties to open the Edit dialog box, 
where you can edit the properties.

Showing Conversion Results

Similarly to conversions done in the main window, click (with the mouse left button) a convert-from unit 
and right-click a convert-into unit in the Unit List. The conversion results will be shown in the second and 
the third column in the Quick Conversion Table. "The values expressed as the base unit" will be converted
into "the unit chosen by left-click" and shown in the second column, and converted into "the unit chosen 
by right-click" and shown in the third column.



       
Executing Batch Conversions
CONTENTS
 
SuperCon 2000 provides the batch conversion function to instantaneously convert a set of numbers.

Preparing for Batch Conversions

Run a text editor and make a batch conversion data file including a physical quantity name, a unit name 
and values to be converted from as shown below. The number of lines is unlimited.

Length
m: meter;
25.3371;
2.55800;
0.83788;
.......;
.......;
0.00555;
21.8003;
332.552;
0.20375; 

The first line means the physical Quantity is "Length" and the second line means the unit name is "m: 
meter". The physical quantity name and the unit name must exactly match the ones described in the 
conversion table. Note that a semicolon ";" is required after the unit name in the second line. The third line
and the rest are the values to be converted from. A semicolon is also required at each line end.

Save the file as a name such as "Length-Meter.bct" for example. The file extension characters can be 
arbitrarily named.

Choosing Batch Conversion Data File

Choose Start Batch Conversion from the File menu to open Open Batch Conversion Data File dialog box. 
Select the batch conversion data file you made and click the OK button. The physical quantity specified in
the file will be selected, the Unit List be updated, and the unit name be shown in the second panel on the 
status bar.

Executing Batch Conversion

Right-click a unit name to be converted into or its icon in the Unit List. The unit name will be shown in the 
fourth panel on the status bar. At this moment the conversion results are added in the batch conversion 
data file. Run a text editor and open the batch conversion data file to confirm what's been done. The 
example below shows the result when the unit to be converted into is "ft: foot":

Length
m: meter; ft: foot;
25.3371; 83.126969;
2.55800; 8.3923885;
0.83788; 2.7489501;
.......; .........
.......; .........
0.00555; 0.018208661;
21.8003; 71.523294;
332.552; 1091.0499;



0.20375; 0.66847113;

As you right-click the unit name or its icon in the Unit List, new results are added as shown below:

Length
m: meter; ft: foot; yd: yard;
25.3371; 83.126969; 27.708990;
2.55800; 8.3923885; 2.7974628;
0.83788; 2.7489501; 0.91631671;
.......; .........; .........;
.......; .........; .........;
0.00555; 0.018208661; 0.0060695538;
21.8003; 71.523294; 23.841098;
332.552; 1091.0499; 363.68329;
0.20375; 0.66847113; 0.22282371;

Quitting Batch Conversion

Choose Quit Batch Conversion from the File menu to get back to the regular conversion mode.

Some sensible users may wonder why we do not use Excel. They may be correct. The only merit to use 
this function is that they do not have to remember a numerous number of unit properties. The 
effectiveness totally depends on for what purpose you use this function.



       
Category Properties Dialog Box
CONTENTS

Right-click the root item or its icon to show the pop-up menu, where you choose Properties to open the 
Category Properties dialog box.

Name ([N])

Enter a unique category name.

Icon ([I])     
 
 

Choose one of the four icons.



       
Open Batch Conversion Data File Dialog Box
CONTENTS

This dialog box opens when you choose Start Batch Conversion from the File menu.

In this dialog box you choose a batch conversion data file. Click the OK button after choosing a file name 
to start batch conversion.        



       
About Keyboard Shortcuts
CONTENTS

The description such as ([N]) or ([Ctrl]+[P]) in the pages that follow denotes the keyboard shortcuts for 
quick access to the specific commands. The keyboard shortcuts are disabled when the window or the 
dialog box including the shortcuts is not active, or a text box in the dialog box is focused.






